Beta Feedback - We need your help 🙏🏼

Dear All,

I hope you all had a good weekend. Great news we are now in Beta and it is time for us to work together to improve the product. I wanted to mention the importance of feedback in the Beta Phase as this is crucial for us to identify areas for improvement before the public go-live. So, please we would like everyone to critically review the app, book a vendor, onboard as a vendor etc and provide feedback. Please note at this stage, all data and profiles on the platform are not live data. I would appreciate it if you can follow the below guide or use this platform to send any feedback or comments and we would aim to respond to you asap.


Step 1: Download TestFlight via the app store

Step 2: Accept the Test flight invitation sent to your email from us (please check your junk if not in your inbox)

Step 3: Tap " View in TestFlight” or “Start testing” then tap “Install” or “Update” to start testing the app.


For iOS or iPadOS:

Open the TestFlight app on your device.

From the Apps list, tap the app.

Tap Send Beta Feedback.

In the share dialogue, tap Include Screenshot to choose a screenshot. If you don’t want to send an attachment, tap Don’t Include Screenshot.

Add your comments (up to 4,000 characters), and optionally enter your email address if you were invited with a public link.

Tap Submit.


When you take a screenshot while testing a beta app or beta App Clip, you can send the screenshot with feedback directly to the developer without leaving the app or App Clip Experience. Developers can opt out of receiving this type of feedback, so this option is only available if the developer has it enabled.

For iOS or iPadOS:

Take a screenshot on your device. For details on how to take screenshots, see Take a screenshot on your iPhone, Take a screenshot on your iPad, and Take a screenshot on your iPod touch.

A thumbnail of your screenshot appears in the lower-left corner of your device. Tap the thumbnail and, if needed, add drawings and text with Markup. Then tap Done.

Tap Share Beta Feedback.

Optionally, you can add comments (up to 4,000 characters), and your email address if you were invited with a public link.

Tap Submit.


If you experience a crash while testing the app, you’ll receive an alert asking if you want to send crash details to the developer through TestFlight. When a crash alert displays for TestFlight for iOS, tap Share, add any additional comments, then tap Submit.


Dear All,

Thanks for the positive feedback we have received so far and the issues identified which we are working on and this should be released shortly. In the meantime, it will be good to get feedback from our testers on here. What is your overall feedback so far using the app? :wink:

A post was merged into an existing topic: 40 Adult Birthday Party Ideas (That Put Kids’ Birthday Parties To Shame)

Hello everyone and congratulations on the release.
I love it ,we are finally there.
Lets crack on with polishing the diamond now, ofcourse I went for it right away lol.
I’ve found few issues with
the white space (or spacing) marked with red I acknowledged as I creating my account and tried to make a booking.I’ll only do this on to bite size feedback as I see it as counterproductive of loading tons of info.

Also the on the first photo is where I’m being prompted to start from even if I’ve closed the app. “List your services” it should be for vendors only and i registered as customer, I even started booking an event lol .
Also please let me know if here is the right place to post everything when testing.


Thank you for your feedback as always. I will merge this conversation into the right topic for beta testing. Some of these issues shouldn’t actually appear as we had it resolved a few weeks ago. It would be good to know what phone your using so we can ask the developers to ensure these issues are fixed for each screen size and fully dynamic in relation to the date that should be available in our next update

Hi @YJames ,

I’m using Samsung S10plus
Thank you

1 Like

@StrikeLog thanks for your feedback, this is really helpful and the kind of information we want to see. It will enable us to address these issues as we prepare for the launch. We would look into it and keep you updated here once they have been addressed. Please keep the feedback coming, we sure appreciate your support as always.


The app looks great! So much detail looks to have gone into it!
Absolutely lived the start up screen with the event clips.
Ive registered, but trying to log in i then get a strange [object][object] error

Thank you, we will look into this today and try to figure at what this may be. In the meantime try to perhaps reset your password to see, whether that might help. Also it would be good to know the type of android phone you are using so that this can be cascaded down to the DEV guys!

Galaxy S20+

Ill try the password reset and get back to you

Edit: reset the password and i have the same issue

Thanks, the team is looking into your case to find out exactly whats going on. Just to confirm this happens both with your Email and Username?

Hi guys,
Sorry if I’m pain but I was looking forward to hunt down flows, bugs and imperfections lol and now I’m stuck.
Just a friendly reminder on my situation.
I’m using Galaxy S10+ so I got the app installed and managed to create an account but as i was fiddling with the app I end up on the page shown on the screenshot. Not sure is this how it supposed to be (i doubt it) but even when I leave the app and than go back in, it lands me on the same page.
If my logic is correct I shouldn’t be send to it as I’m not a vendor (by the way on the landing page I didn’t notice any prompt of choice weather you wanna register as customer or vendor, unless I’m missing something).
Looking forward to get back in
it and fidle with the app, next step will be the most obvious, verification and it would be nice if we can connect via the app with someone (investor, founder etc.) to test the interaction features like messages, photo send/receive etc.
Many thanks guys.
Fabulous, you are nailing it

@StrikeLog, in other to leave a page on an app you might need to close the app entirely and when next you go in it should take you to the explore page (home page). This is how apps should work so can you try it if you haven’t. Also, there is a back button at the top left close to the time, we know the position is not correct so this has been logged with the dev team and they are working on it to bring it down close to “List” so people can easily see it. Please try closing the app and try again and we look forward to more feedback from you.

@OshomaZ ,
As I mentioned earlier, even if I leave/close the app, than open it agen after the logo and the “Featured on Forbs” I’m prompted on the page from screenshot I’ve sent.

There is absolutely nothing arround the word “List” for me to go back to home page, but even if there was, once the app is closed I shouldn’t be sent to the same page,right?
Like you said,just like with every other app once closed, when start it again it should send you to the home page.

Just an update … im all logged in!

1 Like

Might just be my phone but no amount of scrolling will allow me to see what the very bottom event is.

Will there be a pub landlord type option? Pubs up and down the country book bands etc every week. Hit that community hard amd youll be seen and used by 1000s of pub owners and many more tipsy locals


We are currently working on this problem. In short, the page you are on is for creating a vendor profile. The “go back button” shows up too high up on your screen (you can see it in your screenshot underneath your phone’s time at the top of the screen), and so it can’t be pressed.

There currently are 2 ways you can leave this screen until the problem is fixed:

  1. Go to the app’s settings on your phone (long press on the app icon, press the “i” icon), scroll down to the “Storage” section and tap it. Lastly, clear the app’s cache and data and this will reset the app for you.
  2. Simply finish setting up your vendor profile. Begin by selecting a service type and pressing continue.

Fantastic, was it the password change? Or did the insert object disappear?

It just worked the next day, i assumed you guys sorted it :sweat_smile:

It’s something we have spotted on android on a few phones, we aiming to resolve this with one of our next updates.

1 Like